Симулятор Cisco – GNS3

Software


GNS3 (graphical network simulator) – мощный симулятор, выпускаемый под свободной лицензией и позволяющий эмулировать сети большого размера. Полезен администраторам и инженерам, а также пользователям, которые готовятся к сдаче сертификатов Cisco (CCNA, CCNP, CCIP, CCIE) и Juniper Networks (JNCIA, JNCIS, JNCIE). Требует наличия пакетов – Dynamips, Dynagen и Qemu. Для захвата пакетов потребуется Wireshark. Кроме образов Cisco IOS, GNS3 умеет работать с olive образами JunOS.

Возможна эмуляция простых Ethernet, ATM и Frame Relay свитчей и файеров (ASA, PIX). Позволяет подключить виртуальный свитч к сетевой карте реальной или виртуальной системы. Все настройки производятся в интуитивно понятной графической среде.

Читать дальше

Сброс пароля на Cisco 28XX

Полезности
Cброс пароля на маршрутизаторах Cisco осуществляется через консоль, для этого в терминале, я например пользуюсь Minicom, нужно послать Break в первіе 60 секунд после включения питания. В Minicom Break посылается комбинацией клавиш Ctrl-a f, в виндовом гипертерминале Ctrl-Break.
После нажатия вы вывалитесь в командную строку rmon. Віглядит это так:
rommon 1 >

В это приглашение вбиваем:
confreg 0x2142

В ответ вы должны увидеть:
You must reset or power cycle for new config to take effect
rommon 2 >

Теперь вводим:
reset

И после перезагрузки маршрутизатор поднимется с пустым конфигом и предложит провести настройку.
— System Configuration Dialog — Would you like to enter the initial configuration dialog? [yes/no]:


Читать дальше

IPSec туннель между Cisco и CentOS Linux

Руководство
Имеем:
1. Маршрутизатор Cisco 5510 ASA с реальным IP 1.1.1.1 (сеть XXX.XXX.0.0/24)
2. Маршрутизатор Linux CentOS 5.2 (ядро 2.6.18-92.el5) с установленным
ipsec-tools-0.6.5-13.el5_3.1 и реальным IP 2.2.2.2 (сеть XXX.XXX.0.0/16)

Конфигурация на маршрутизаторе Cisco:

crypto isakmp policy 5
    encr aes
    authentication pre-share
    group 2
    lifetime 3600
    hash sha
   !
   crypto isakmp key SECRETKEY address 2.2.2.2
   crypto ipsec security-association lifetime seconds 3600
   crypto ipsec transform-set GK esp-aes esp-sha-hmac
   crypto map IPSec 7 ipsec-isakmp
   set peer 2.2.2.2
   set transform-set GK
   set pfs group2
   match address 666
  !
  interface GigabitEthernet0/0.1
   ip address 1.1.1.1 255.255.255.224
   crypto map IPSec
  !
  ip route XXX.XXX.0.0 255.255.255.0 2.2.2.2
  access-list 666 remark asGK
  access-list 666 permit ip  XXX.XXX.0.0 0.0.255.255  XXX.XXX.0.0 0.0.0.255
  access-list 666 deny   ip any any


Читать дальше