Использование Clonezilla для клонирования дисков с загрузкой по сети

Заметки
Clonezilla (http://clonezilla.org/) позволяет быстро клонировать диски, способом сходным с проприетарным продуктом Norton Ghost. При создании копии переносятся только занятые блоки данных, пустые области пропускаются. Поддерживается режим массового клонирования в multicast режиме, например, при тестировании, за 10 минут удалось провести клонирование исходного 5.6 Гб диска на 41 клиентскую машину. Поддерживаются ФС: ext2, ext3, ext4, reiserfs,reiser4, xfs, jfs, FAT, NTFS, UFS, HFS+ (Mac OS X).

Для организации сервера для загрузки Clonezilla по сети (PXE), можно использовать следующую инструкцию для CentOS.

Настраиваем NFS-сервер:

mkdir -p /mnt/isoimage 
   mkdir -p /exports/clonezilla

Загружаем clonezilla-live-*.iso с сайта clonezilla.org в директорию
/tmp, монтируем iso-образ и копируем его содержимое в директорию /exports/clonezilla:

mount -o loop /tmp/clonezilla-live-$LATESTVERSION.iso /mnt/isoimage  
   cp -a /mnt/isoimage/. /exports/clonezilla
   umount /mnt/isoimage 

В /etc/exports добавляем:

/exports/clonezilla *(ro,sync)


Читать дальше

IPSec туннель между Cisco и CentOS Linux

Руководство
Имеем:
1. Маршрутизатор Cisco 5510 ASA с реальным IP 1.1.1.1 (сеть XXX.XXX.0.0/24)
2. Маршрутизатор Linux CentOS 5.2 (ядро 2.6.18-92.el5) с установленным
ipsec-tools-0.6.5-13.el5_3.1 и реальным IP 2.2.2.2 (сеть XXX.XXX.0.0/16)

Конфигурация на маршрутизаторе Cisco:

crypto isakmp policy 5
    encr aes
    authentication pre-share
    group 2
    lifetime 3600
    hash sha
   !
   crypto isakmp key SECRETKEY address 2.2.2.2
   crypto ipsec security-association lifetime seconds 3600
   crypto ipsec transform-set GK esp-aes esp-sha-hmac
   crypto map IPSec 7 ipsec-isakmp
   set peer 2.2.2.2
   set transform-set GK
   set pfs group2
   match address 666
  !
  interface GigabitEthernet0/0.1
   ip address 1.1.1.1 255.255.255.224
   crypto map IPSec
  !
  ip route XXX.XXX.0.0 255.255.255.0 2.2.2.2
  access-list 666 remark asGK
  access-list 666 permit ip  XXX.XXX.0.0 0.0.255.255  XXX.XXX.0.0 0.0.0.255
  access-list 666 deny   ip any any


Читать дальше

Вышел VoIP-ориентированный дистрибутив DigAnTel 3

GNU/Linux
Представлен релиз Linux-дистрибутива DigAnTel 3, ориентированного на быстрое развертывание унифицированных серверов для обеспечения работы VoIP-телефонии дома или на предприятии. В качестве основы используется CentOS, Asterisk 1.4.30, DAHDI 2.3.0, FreePBX 2.7.0 с модулем VoicePulse. Дополнительно в состав входит Jabber-сервер Openfire, система управления взаимоотношениями с клиентами vtigerCRM, а также Postfix и OpenVPN.

Установка VoIP-сервера производится в автоматическом режиме и не требует навыков по настройке Linux и Asterisk. Система поддерживает работу как с традиционными аналоговыми телефонами, так и с цифровыми T1/PRI потоками и VOIP-каналами. Размер установочного iso-образа составляет 690 Мб.

Вышел CentOS 5.5

GNU/Linux

CentOS является бесплатной версией промышленного дистрибутива Red Hat Enterprise Linux (RHEL) и на 100% бинарно совместим с ним. Но в отличие от RHEL, для которого бинарные обновления предоставляются только на время ознакомительного срока либо при наличии контракта на поддержку, CentOS не ограничивает доступ к бинарным обновлениям.

CentOS 5.5 наследует все улучшения, введенные в RHEL 5.5. С их полным списком можно ознакомиться в новости о выходе RHEL 5.5. Кратко напомню наиболее интересные моменты:

Читать дальше