Авторизация

Вы можете войти через одну из учетных записей:

ИЛИ



Напомнить пароль
Регистрация

Есть вопрос!libasound

C недавних пор перестал работать скайп. И мне кажется это навеяно той же проблемой по которой перестал воспроизводить звуки флеш-плеер на веб-страницах. В частности на ютубе. Имеется такой вот лог:

boss@linux-6b6t:> skype
skype: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64
boss@linux-6b6t:> ldd /usr/bin/skype | grep not
  libasound.so.2 => not found
boss@linux-6b6t:> sudo zypper install libasound2-32bit
Загрузка данных о репозиториях...
Чтение установленных пакетов...
'libasound2-32bit' уже установлен.
Нет кандидатов на обновление 'libasound2-32bit'.
Разрешение зависимостей пакетов...

Нечего выполнять.


может что посоветуете, что делать дальше? Чем вызвано это всё не понятно. Быть может после установки каких-то обновлений критических, что предлагаются периодически в openSUSE.

HTML5 не предлагайте. Не смотреть ютуб тоже :). Пока смотрю в проге minitube, что использует Phonon, но это не выход. В конце концов видео в избранное хочется добавить ну и так далее.

Комментарии (10) Вконтакте (0) facebook (0)

Комментарии (10)

rss свернуть / развернуть
Мне кажется проблема с библиотеками, попробуй удалить skype и flash (полностью) и заново всё поставить…
свернуть ветку
Переустановил и то и другое. Не помогло…
свернуть ветку
Вот такая вот фишка…
У вас по имени libasound.so.2 64-битная версия, и потребуется дополнительное телодвижение, чтобы вам 32-битный скайп на 64-битной системе обращался к 32-битной libasound.so. Спасти от геморроя могла бы 64-битная версия скайпа, но скайповцы его не осилили кроме как для убунты...

свернуть ветку
И как же его заставить обращаться к 32-битной библе?
свернуть ветку
Я конвертил deb64 пакет тулзой alien в rpm. Очевидно должен получиться 64-битный rpm. Но даже в таком случае скайп выдаёт ту же ошибку.
свернуть ветку
  • avatar
  • BUM
  • 15 июня 2010, 12:21
  • #
  • 0
У меня та же хрень на федоре с MainActor
[bum@notebook ~]$ cd /opt/MainConcept/MainActor/
[bum@notebook MainActor]$ ./mactor 
./mactor: error while loading shared libraries: libaudio.so.2: cannot open shared object file: No such file or directory
[bum@notebook MainActor]$ 

свернуть ветку
У вас просто нет библиотеки
свернуть ветку
таки да :))) когда ставил МейнАктёр кто-то отвлек и провтыкал поставить nas-libs :)
свернуть ветку
Как не странно. у меня тоже после апа звук отпал. Но помогает только service alsasound restart. Хотя kde у меня factory. Так что судить не могу…
свернуть ветку

Только авторизованные пользователи могут оставлять комментарии. Авторизуйтесь, пожалуйста.