Авторизация

Вы можете войти через одну из учетных записей:

ИЛИ



Напомнить пароль
Регистрация
+5.86

avatar Руководство

Руководство, документации

Администраторы (1): Diesel
Модераторы (0): Модераторов здесь не замечено
Читатели (10): Brabus machete Guf android BUM doctor-demon linux_news shell pavel_nesterow apple

РуководствоIPSec туннель между Cisco и CentOS Linux

Имеем:
1. Маршрутизатор Cisco 5510 ASA с реальным IP 1.1.1.1 (сеть XXX.XXX.0.0/24)
2. Маршрутизатор Linux CentOS 5.2 (ядро 2.6.18-92.el5) с установленным
ipsec-tools-0.6.5-13.el5_3.1 и реальным IP 2.2.2.2 (сеть XXX.XXX.0.0/16)

Конфигурация на маршрутизаторе Cisco:

crypto isakmp policy 5
    encr aes
    authentication pre-share
    group 2
    lifetime 3600
    hash sha
   !
   crypto isakmp key SECRETKEY address 2.2.2.2
   crypto ipsec security-association lifetime seconds 3600
   crypto ipsec transform-set GK esp-aes esp-sha-hmac
   crypto map IPSec 7 ipsec-isakmp
   set peer 2.2.2.2
   set transform-set GK
   set pfs group2
   match address 666
  !
  interface GigabitEthernet0/0.1
   ip address 1.1.1.1 255.255.255.224
   crypto map IPSec
  !
  ip route XXX.XXX.0.0 255.255.255.0 2.2.2.2
  access-list 666 remark asGK
  access-list 666 permit ip  XXX.XXX.0.0 0.0.255.255  XXX.XXX.0.0 0.0.0.255
  access-list 666 deny   ip any any

Читать дальше
  • +1
  • Diesel
  • 16 сентября 2010, 03:02
  • add twitter 

РуководствоТюнинг LVM, RAID, XFS и EXT3 при интенсивной обработке мелких файлов

Рекомендации по тюнингу некоторых системных параметров в Debian/GNU Linux для оптимизации работы высоконагруженных систем, производящих тысячи одновременных запросов к массиву из десятка миллионов мелких файлов (например, типичная
ситуация для нагруженного почтового сервера с maildir). В итоге удалось снизить время ожидания процессором завершения ввода/вывода (I/O wait) для XFS с 30% до 0.3%, а для EXT3 до 5%.

Для увеличения производительности при большом числе параллельных дисковых операций рекомендуется использовать хранилища, подключенные через Fiber Channel, и использовать технологию Multipath для организации доступа к
хранилищу, подключенному через несколько каналов (путей) ввода/вывода.

Повысить производительность можно подключив несколько дисков в LVM и RAID, используя «striping»-режим без контроля целостности. Оптимальная производительность для программного RAID при обработке небольших файлов достигается при размере stripe-блока 4 Мб и размере chunk-а 256 Кб. Важное значение имеет также выравнивание файловых систем, LVM и RAID относительно внутренней группировки дисков в хранилище (учитываем физические параметры массива для логически предоставляемого хранилищем раздела).

Например, имея хранилище IBM DS 8300 из 8 дисков, подключенных по Fiber
Channel и объединенных в RAID5, будет использовать разбиение на 8 каналов ввода/вывода:
Читать дальше
  • +1
  • android
  • 14 сентября 2010, 16:23
  • add twitter 

РуководствоActiveSync под linux

Пошаговая настройка со сборкой из исходников уже есть, а я собрал всё это в пакеты для Gutsy за исключением пропатченного модуля ядра.

Итак для WM5 и WM6 (для WM2003 пока инструкций нет.):
Для того чтобы подключить кпк к линуксу через ActiveSync нужно.

1) Пропатчить модуль
для ядра >=2,6,21патч доступен тут

у меня ядро 2.6.22
если у вас абсолютно та же версия( узнать об этом можно по командой uname -r )
для ядра 2.6.22-14-386 пропатченный модуль доступен тут ftp://80.86.249.14/forum/synce/rndis_host.ko
для ядра 2.6.22-14-generic пропатченный модуль доступен тут ftp://80.86.249.14/forum/synce/rndis_host.ko.generic
, его нужно скопировать в /lib/modules/2.6.22-14-386/kernel/drivers/net/usb, заменив оригинальный.
И можно перейти к шагу №2
Читать дальше
  • 0
  • Diesel
  • 12 сентября 2010, 21:39
  • add twitter 

РуководствоУстановка и настройка сервера nginx с поддержкой PHP в Debian / Ubuntu

Nginx — высоко производительный HTTP сервер, распространяемый с вместе с исходными кодами. Nginx стал популярным благодаря своей стабильности, богатому набору возможностей, простой конфигурацией и небольшим потреблением системных ресурсов.

Встроенной поддержки PHP в nginx нет, но есть возможность работы с FastCGI. Благодаря этому, а так же fastcgi демону spawn-fcgi, идущего вместе с сервером lighttpd, PHP-сайты могут вполне благополучно работать под nginx.

Установка и настройка PHP
Установка PHP не отличается от установки какого-либо другого пакета в Debian / Ubuntu. Выполняем установку непосредственно PHP(5), а так же поддержку FastCGI в PHP:

$ sudo aptitude install php5 php5-cgi

Настройка PHP
После установки PHP, необходимо сделать некоторые настройки: обеспечить поддержку правильных PATH_INFO/PATH_TRANSLATED в CGI. Для этого необходимо отредактировать файл/etc/php5/cgi/php.ini следующим образом:
Читать дальше
  • +1
  • android
  • 27 августа 2010, 10:43
  • add twitter 

РуководствоУстановка nginx как front-end к apache в Debian / Ubuntu

Рано или поздно перед администратором встает задача разгрузить back-end, которым как правило, является apache. Одной из альтернатив для front-end является легкий web сервер Nginx. Данная конфигурация дает особенно большой выигрыш при наличии подключений по медленным каналам связи (модем), так как ресурсы системы начинают использоваться для дела, а не ждать, пока будет получен запрос или отдан ответ клиенту.

Преимущества архитектуры front-end/back-end
В случае использования только apache, при наличии медленных подключений, последний бОльшую часть времени просто ждет, либо пока будет полностью получен запрос, либо пока будет полностью передан ответ клиенту. При этом под каждое соединение будет выделено определенное количество памяти, и, как не трудно догадаться, общее количество одновременных подключений будет прямо пропорционально доступному объему памяти.

В случае же front-end/back-end конфигурации ситуация немного иная: front-end ( в нашем случае, nginx) полностью обрабатывает входящий запрос, используя при этом минимум системных ресурсов. Передает запрос back-end'у (apache), быстро получает ответ и начинает передачу ответа клиенту. Таким образом, ресурсы, занятые под apache, были использованы только для того, чтобы сгенерировать запрошенный контент, и были сразу возвращены системе после завершения работы. А с клиентом общается лишь легкий и не требовательный к ресурсам front-end nginx.

Общий вид схемы front-end/back-end
В общем виде, http-соединение будет проделывать следующий путь:

HTTP Client  ---->  Front-End (nginx)  ---->  Back-End (apache)
-----------  <----  -----------------  <----  -----------------
1.2.3.4:80          192.168.0.1:80            192.168.0.1:8080

В данном случае, fron-end и back-end располагаются на одной машине. В общем же случае, при необходимости они могут работать на разных машинах.
Читать дальше
  • +1
  • android
  • 27 августа 2010, 10:32
  • add twitter 

РуководствоУстановка и настройка Django, Nginx через Tornado в Debian / Ubuntu

Tornado (торнадо) — это неблокирующий, высоко производительный веб-сервер с открытыми исходным кодом. Авторами сервера являются создатели сервиса FriendFeed. Сервер реализован средствами языка Python и в силу своей неблокирующей природы (используется epoll) легко выдерживает тысячи одновременных подключений. Помимо всего прочего, Tornado поддерживает протокол WSGI, хотя и с небольшими ограничениями (будут не доступны асинхронные фичи сервера).

Учитывая все это, можно предположить, что возможность запуска Django с помощью Tornado может стать достойной альтернативой описанному ранее способу запуска Django через FastCGI. Итак, проверим…

Механизм взаимодействия будет классическим:
front-end — nginx, проксирующий все соединения, кроме статических файлов, на back-end
back-end — tornado + django

Читать дальше
  • 0
  • Diesel
  • 26 августа 2010, 20:25
  • add twitter 

РуководствоGrub2 - выбор OS по-умолчанию

Вариант 1

Для выбора загрузки необходимой нам ОС правим файл /etc/default/grub
sudo gedit /etc/default/grub


Загружаемая по умолчанию ОС указывается в GRUB_DEFAULT=0, где 0 — первый из перечисленных в /boot/grub/grub.cfg вариантов, 1 — второй и т. д.
«0» меняем на соответствующий номер, под которым находится наша ОС в списке (файл /boot/grub/grub.cfg).

Сохраняемся, после чего обязательно выполняем:
sudo update-grub


Пример для тех, кто ничего не понял или понял, но плохо:
Читать дальше
  • +1
  • android
  • 26 августа 2010, 10:48
  • add twitter 

РуководствоПростой способ Конвертации VmWare-образа в образ Virtualbox

Это инструкция по преобразованию Образов дисков VmWare(.vmdk) в образы VirtualBox(.vdi)
sudo apt-get install qemu

Сам qemu нам не нужен, нужен лишь qemu-img из его пакета.
qemu-img convert vmware-disk.vmdk -O raw raw-disk.bin

Распаковываем vmware-диск в raw образ. Внимание, raw образ занимает обьем, примерно в 3.5 раза больший, чем vmware диск.
VBoxManage convertfromraw -format VDI raw-disk.bin virtualbox-disk.vdi

Запаковываем raw в формат Virtualbox
rm raw-disk.bin && sudo aptitude remove qemu

Удаляем raw образ и qemu.
  • 0
  • Diesel
  • 16 августа 2010, 13:09
  • add twitter 

РуководствоМонтирование удалённых FTP и Samba директорий в локальную

Продолжаю тему монтирования удалённых каталогов. В прошлый раз я писал про монтирование через sshfs, или sftp. В этот раз напишу про монтирования samba шар, и ftp. В этот раз обойдусь без предисловия, и преступим сразу к делу :) Предполагается, что у вас уже есть рабочие и настроенные ftp и smb сервера.

Монтирования samba директорий

Для монтирования я предпочитаю использовать cifs который во многих дистрибутивах уже собран в ядре.

Собственно всё монтирование умещается в одну команду:

sudo mount -t cifs //10.10.10.10/share_name /mnt/share_folder -o username=user1,password=userpass,iocharset=utf-8

Читать дальше
  • 0
  • Diesel
  • 27 июля 2010, 16:17
  • add twitter 

РуководствоУдаление неиспользуемых пакетов в Debian GNU/Linux

Для чистки системы от оставшихся после удаления пакетов, неудаленных зависимостей, можно использовать программу deborphan.

По умолчанию deborphan осуществляет поиск неиспользуемых библиотек, но можно указать расширить область охвата на
файлы с данными, dev-пакеты и т.п.

Устанавливаем deborphan:
apt-get install deborphan

Читать дальше
  • 0
  • Diesel
  • 26 июля 2010, 09:35
  • add twitter